package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)'[^\\']*(?:\\.[^\\']*)*'(*SKIP)(*F)|\.(\w+)`)
var str = `$app.url = $cfg.url ? $cfg.url : 'domain.ext'`
var substitution = "[$1]"
fmt.Println(re.ReplaceAllString(str, substitution))
}