const regex = /'[^\\']*(?:\\.[^\\']*)*'(*SKIP)(*F)|\.(\w+)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'[^\\\\\']*(?:\\\\.[^\\\\\']*)*\'(*SKIP)(*F)|\\.(\\w+)', 'gms')
const str = `\$app.url = \$cfg.url ? \$cfg.url : 'domain.ext'`;
const subst = `[$1]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);