$re = '/\'[^\\\\\']*(?:\\\\.[^\\\\\']*)*\'(*SKIP)(*F)|\.(\w+)/ms';
$str = '$app.url = $cfg.url ? $cfg.url : \'domain.ext\'';
$subst = "[$1]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;