use strict;
my $str = '$app.url = $cfg.url ? $cfg.url : \'domain.ext\'';
my $regex = qr/'[^\\']*(?:\\.[^\\']*)*'(*SKIP)(*F)|\.(\w+)/msp;
my $subst = '[$1]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";