import Foundation
let pattern = #"'[^\\']*(?:\\.[^\\']*)*'(*SKIP)(*F)|\.(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"$app.url = $cfg.url ? $cfg.url : 'domain.ext'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$1]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)