re = /'[^\\']*(?:\\.[^\\']*)*'(*SKIP)(*F)|\.(\w+)/m
str = '$app.url = $cfg.url ? $cfg.url : \'domain.ext\''
subst = '[$1]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result