using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'[^\\']*(?:\\.[^\\']*)*'(*SKIP)(*F)|\.(\w+)";
string substitution = @"[$1]";
string input = @"$app.url = $cfg.url ? $cfg.url : 'domain.ext'";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}