using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(-?[.0-9]+)\^(-?[.0-9]+)";
string substitution = @"Math.pow(\\1, \\2)";
string input = @"5^2
8*6^-8
7/6^8+7
7/1.5^8+7-8
.4^0.4
.4+^0.4 (invalid)
5400^.5+2
4.^.5";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}