import Foundation
let pattern = #"(-?[.0-9]+)\^(-?[.0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
5^2
8*6^-8
7/6^8+7
7/1.5^8+7-8
.4^0.4
.4+^0.4 (invalid)
5400^.5+2
4.^.5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Math.pow(\\1, \\2)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)