$re = '/(-?[.0-9]+)\^(-?[.0-9]+)/m';
$str = '5^2
8*6^-8
7/6^8+7
7/1.5^8+7-8
.4^0.4
.4+^0.4 (invalid)
5400^.5+2
4.^.5';
$subst = "Math.pow(\\1, \\2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;