use strict;
my $str = '5^2
8*6^-8
7/6^8+7
7/1.5^8+7-8
.4^0.4
.4+^0.4 (invalid)
5400^.5+2
4.^.5';
my $regex = qr/(-?[.0-9]+)\^(-?[.0-9]+)/mp;
my $subst = 'Math.pow(\\\\1, \\\\2)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";