package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(-?[.0-9]+)\^(-?[.0-9]+)`)
var str = `5^2
8*6^-8
7/6^8+7
7/1.5^8+7-8
.4^0.4
.4+^0.4 (invalid)
5400^.5+2
4.^.5`
var substitution = "Math.pow(\\1, \\2)"
fmt.Println(re.ReplaceAllString(str, substitution))
}