const regex = new RegExp('(-?[.0-9]+)\\^(-?[.0-9]+)', 'gm')
const str = `5^2
8*6^-8
7/6^8+7
7/1.5^8+7-8
.4^0.4
.4+^0.4 (invalid)
5400^.5+2
4.^.5`;
const subst = `Math.pow(\\1, \\2)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);