# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(-?[.0-9]+)\^(-?[.0-9]+)"
test_str = ("5^2\n"
"8*6^-8\n"
"7/6^8+7\n"
"7/1.5^8+7-8\n"
".4^0.4\n"
".4+^0.4 (invalid)\n"
"5400^.5+2\n"
"4.^.5")
subst = "Math.pow(\\\\1, \\\\2)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.