// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(-?[.0-9]+)\^(-?[.0-9]+)").unwrap();
let string = "5^2
8*6^-8
7/6^8+7
7/1.5^8+7-8
.4^0.4
.4+^0.4 (invalid)
5400^.5+2
4.^.5";
let substitution = "Math.pow(\\\\1, \\\\2)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}