package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\$2[ayb]\$.{56}$`)
var str = `$2a$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2b$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2y$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2z$abcdefghij1234567890abcdefghij1234567890abcdefghij123456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}