$re = '/^\$2[ayb]\$.{56}$/m';
$str = '$2a$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2b$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2y$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2z$abcdefghij1234567890abcdefghij1234567890abcdefghij123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);