const regex = /^\$2[ayb]\$.{56}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\$2[ayb]\\$.{56}$', 'gm')
const str = `\$2a\$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
\$2b\$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
\$2y\$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
\$2z\$abcdefghij1234567890abcdefghij1234567890abcdefghij123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}