// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\$2[ayb]\$.{56}$").unwrap();
let string = "$2a$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2b$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2y$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2z$abcdefghij1234567890abcdefghij1234567890abcdefghij123456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}