import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\$2[ayb]\\$.{56}$";
final String string = "$2a$abcdefghij1234567890abcdefghij1234567890abcdefghij123456\n"
+ "$2b$abcdefghij1234567890abcdefghij1234567890abcdefghij123456\n"
+ "$2y$abcdefghij1234567890abcdefghij1234567890abcdefghij123456\n\n"
+ "$2z$abcdefghij1234567890abcdefghij1234567890abcdefghij123456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}