import re
regex = re.compile(r"^\$2[ayb]\$.{56}$", flags=re.MULTILINE)
test_str = ("$2a$abcdefghij1234567890abcdefghij1234567890abcdefghij123456\n"
"$2b$abcdefghij1234567890abcdefghij1234567890abcdefghij123456\n"
"$2y$abcdefghij1234567890abcdefghij1234567890abcdefghij123456\n\n"
"$2z$abcdefghij1234567890abcdefghij1234567890abcdefghij123456")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")