re = /^\$2[ayb]\$.{56}$/m
str = '$2a$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2b$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2y$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2z$abcdefghij1234567890abcdefghij1234567890abcdefghij123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end