import Foundation
let pattern = #"^\$2[ayb]\$.{56}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$2a$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2b$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2y$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
$2z$abcdefghij1234567890abcdefghij1234567890abcdefghij123456
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)