using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"rtl_433\/r4-64\/devices\/([^\/:]+)\/([^\/:]+).*:.*";
string input = @"rtl_433/r4-64/devices/AmbientWeather-TX8300/1/108/mic:
rtl_433/r4-64/devices/AlectoV1-Wind/1/36/mic:";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}