package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)rtl_433\/r4-64\/devices\/([^\/:]+)\/([^\/:]+).*:.*`)
var str = `rtl_433/r4-64/devices/AmbientWeather-TX8300/1/108/mic:
rtl_433/r4-64/devices/AlectoV1-Wind/1/36/mic:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}