re = /rtl_433\/r4-64\/devices\/([^\/:]+)\/([^\/:]+).*:.*/m
str = 'rtl_433/r4-64/devices/AmbientWeather-TX8300/1/108/mic:
rtl_433/r4-64/devices/AlectoV1-Wind/1/36/mic:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end