const regex = /rtl_433\/r4-64\/devices\/([^\/:]+)\/([^\/:]+).*:.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('rtl_433\\\/r4-64\\\/devices\\\/([^\\\/:]+)\\\/([^\\\/:]+).*:.*', 'gm')
const str = `rtl_433/r4-64/devices/AmbientWeather-TX8300/1/108/mic:
rtl_433/r4-64/devices/AlectoV1-Wind/1/36/mic:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}