import re
regex = re.compile(r"rtl_433\/r4-64\/devices\/([^\/:]+)\/([^\/:]+).*:.*", flags=re.MULTILINE)
test_str = ("rtl_433/r4-64/devices/AmbientWeather-TX8300/1/108/mic:\n"
"rtl_433/r4-64/devices/AlectoV1-Wind/1/36/mic:")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")