// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)rtl_433\/r4-64\/devices\/([^\/:]+)\/([^\/:]+).*:.*").unwrap();
let string = "rtl_433/r4-64/devices/AmbientWeather-TX8300/1/108/mic:
rtl_433/r4-64/devices/AlectoV1-Wind/1/36/mic:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}