import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "rtl_433\\/r4-64\\/devices\\/([^\\/:]+)\\/([^\\/:]+).*:.*";
final String string = "rtl_433/r4-64/devices/AmbientWeather-TX8300/1/108/mic:\n"
+ "rtl_433/r4-64/devices/AlectoV1-Wind/1/36/mic:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}