# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<p\b[^<>\\/]*>\s*(<img\b[^<>]*>)\s*<\\/p>/$1/gm;t' <<< "<p class=\"text\">test</p><p class=\"image\"> <img src=\"vvv\" /> </p>"