$re = '/<p\b[^<>\/]*>\s*(<img\b[^<>]*>)\s*<\/p>/m';
$str = '<p class="text">test</p><p class="image"> <img src="vvv" /> </p>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;