package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<p\b[^<>\/]*>\s*(<img\b[^<>]*>)\s*<\/p>`)
var str = `<p class="text">test</p><p class="image"> <img src="vvv" /> </p>`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}