re = /<p\b[^<>\/]*>\s*(<img\b[^<>]*>)\s*<\/p>/m
str = '<p class="text">test</p><p class="image"> <img src="vvv" /> </p>'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result