const regex = /<p\b[^<>\/]*>\s*(<img\b[^<>]*>)\s*<\/p>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p\\b[^<>\\\/]*>\\s*(<img\\b[^<>]*>)\\s*<\\\/p>', 'gm')
const str = `<p class="text">test</p><p class="image"> <img src="vvv" /> </p>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);