import re
regex = re.compile(r"<p\b[^<>\/]*>\s*(<img\b[^<>]*>)\s*<\/p>", flags=re.MULTILINE)
test_str = "<p class=\"text\">test</p><p class=\"image\"> <img src=\"vvv\" /> </p>"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)