#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<p\b[^<>\/]*>\s*(<img\b[^<>]*>)\s*<\/p>"
Local $sString = "<p class="text">test</p><p class="image"> <img src="vvv" /> </p>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)