use strict;
my $str = '<p class="text">test</p><p class="image"> <img src="vvv" /> </p>';
my $regex = qr/<p\b[^<>\/]*>\s*(<img\b[^<>]*>)\s*<\/p>/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";