# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\\+CPIN: (.+)(,(.+))?$/\g<0>/ig;t' <<< "+CPIN: MT PIN-UNLOCKED"