re = /^\\+CPIN: (.+)(,(.+))?$/i
str = '+CPIN: MT PIN-UNLOCKED'
subst = '\\g<0>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result