// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^\\+CPIN: (.+)(,(.+))?$").unwrap();
let string = "+CPIN: MT PIN-UNLOCKED";
let substitution = "\\g<0>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}