import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?(Found no active cells!|CellId(.*\\n)*.*))|(uehId:.*)";
final String string = "FXL260> ue print -admitted\n"
+ "Trying rbs's password from uservariable com_password ...OK\n"
+ "....\n"
+ "190830-12:11:22 10.86.28.138 19.0g stopfile=/tmp/74752\n"
+ "coli>/lrat/ue print -admitted\n"
+ "CellId #UE:s #Bearers \n"
+ " 1 53 72\n"
+ " 2 9 14\n"
+ " 3 38 52\n"
+ " 101 0 0\n"
+ " 102 0 0\n"
+ " 103 0 0\n"
+ "coli>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}