use strict;
my $str = 'FXL260> ue print -admitted
Trying rbs\'s password from uservariable com_password ...OK
....
190830-12:11:22 10.86.28.138 19.0g stopfile=/tmp/74752
coli>/lrat/ue print -admitted
CellId #UE:s #Bearers
1 53 72
2 9 14
3 38 52
101 0 0
102 0 0
103 0 0
coli>
';
my $regex = qr/(.*?(Found no active cells!|CellId(.*\n)*.*))|(uehId:.*)/sip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}