import Foundation
let pattern = #"(.*?(Found no active cells!|CellId(.*\n)*.*))|(uehId:.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = ##"""
FXL260> ue print -admitted
Trying rbs's password from uservariable com_password ...OK
....
190830-12:11:22 10.86.28.138 19.0g stopfile=/tmp/74752
coli>/lrat/ue print -admitted
CellId #UE:s #Bearers
1 53 72
2 9 14
3 38 52
101 0 0
102 0 0
103 0 0
coli>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}