#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)\$(\d+)[\,]*([\.]*\d*)"
Local $sString = "a|b|c" & @CRLF & _
"" & @CRLF & _
"$1,000|hi,you|$45.43" & @CRLF & _
"" & @CRLF & _
"$300.03|$MS2|$55,000"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)