import re
regex = re.compile(r"\$(\d+)[\,]*([\.]*\d*)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("a|b|c\n\n"
"$1,000|hi,you|$45.43\n\n"
"$300.03|$MS2|$55,000")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)