use strict;
my $str = 'a|b|c
$1,000|hi,you|$45.43
$300.03|$MS2|$55,000';
my $regex = qr/\$(\d+)[\,]*([\.]*\d*)/imp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";