re = /\$(\d+)[\,]*([\.]*\d*)/im
str = 'a|b|c
$1,000|hi,you|$45.43
$300.03|$MS2|$55,000'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result