import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$(\\d+)[\\,]*([\\.]*\\d*)";
final String string = "a|b|c\n\n"
+ "$1,000|hi,you|$45.43\n\n"
+ "$300.03|$MS2|$55,000";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}