using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$(\d+)[\,]*([\.]*\d*)";
string substitution = @"$1$2";
string input = @"a|b|c
$1,000|hi,you|$45.43
$300.03|$MS2|$55,000";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}